[Mono-list] Problems with compiling XSP 0.8

Joshue jmartin@projectsoftware.com
Fri, 23 Jan 2004 09:51:24 +0100


         I want to server ASP.NET pages but I can't complie XSP 0.8

         The machine where I have tried to install is a Linux Slackware 8.0 

         I have installed mono (mono-0.29.tar.gz) with pkg-config (0.15), 
glib (2.3.1), autoconf (2.59) and ICU4C 2.6.1). The instalation of mono was 
made with:
         ./configure --prefix=/usr/local/ --with-gc=none
         (without the --witht-gc=none switch it compiles but when I try to 
compile some .cs examples it makes a segmentation fault)
         make install

         I can compile and execute the samples/embed example, and some 
"hello world" examples without embedding.

         I have installed mod_mono-0.6.tar.gz. First I had problems because 
the installation incorrectly detected my Apache-2.0.48 like a "Apache 1.3", 
so I had to change the configure script for always detecting an Apache 2 
version. The instalation was:

         ./configure --prefix=/usr/local/mod-mono 
         make install

         Then, I tried to install xsp-0.8.tar.gz:
         ./configure --prefix=/usr/local/xsp
          and it displayed:

Making all in doc
make[1]: Entering directory `/usr/local/src/xsp-0.8/doc'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/usr/local/src/xsp-0.8/doc'
Making all in server
make[1]: Entering directory `/usr/local/src/xsp-0.8/server'
/usr/local/bin/mcs -debug+ -debug:full -nologo -r:System.Web.dll 
/out:xsp.exe IA
pplicationHost.cs XSPApplicationHost.cs MonoWorkerRequest.cs 
t.cs Tracing.cs server.cs AssemblyInfo.cs XSPWorkerRequest.cs
In type: Mono.ASPNET.HttpErrors

Unhandled Exception: System.NullReferenceException: A null value was found 
  an object instance was required
in (unmanaged) (wrapper managed-to-native) 
eate_runtime_class (System.Reflection.Emit.TypeBuilder)
in <0x00004> (wrapper managed-to-native) 
te_runtime_class (System.Reflection.Emit.TypeBuilder)
in <0x003dd> System.Reflection.Emit.TypeBuilder:CreateType ()
in <0x00092> Mono.CSharp.TypeContainer:CloseType ()
in <0x000df> Mono.CSharp.TypeContainer:CloseType ()
in <0x00640> Mono.CSharp.RootContext:CloseTypes ()
in <0x0086c> Mono.CSharp.Driver:MainDriver (string[])
in <0x0001b> Mono.CSharp.Driver:Main (string[])

make[1]: *** [xsp.exe] Error 1
make[1]: Leaving directory `/usr/local/src/xsp-0.8/server'
make: *** [all-recursive] Error 1

         If I download the XSP trought the CVS:
         ./autogen.sh --prefix=/usr/local/xsp
          it displays the same error as the xsp-0.8.tar.gz package.

         What can I do?