[Mono-list] Mono Windows/Cygwin Repeatable Build Process

Joe Mozelesky jmozelesky@netcarrier.com
Sun, 4 Jan 2004 22:37:52 -0500 (EST)


I was wondering if there were any plans to update mono-build-w32.sh to a
working state, or if there is a working build script for Windows/Cygwin
floating around out there?  I just spent the past 2 days trying to compile
Mono on Cygwin.  I did a fresh install of Cygwin, and I selected to
install _everything_.  I have tried building using mono-build-w32.sh, and
I have tried building from a tarball, and I have tried checking it out
from CVS and building it manually.

I keep running into one problem after another.  There is no single
document describing what is required for a successful build.  Following
the instructions in the Mono handbook does not work.  There are a lot of
posts in the mailing list archives about various common problems like
libgc not found, autoconf version issues, etc.  I have messed with various
ACLOCAL_FLAGS, PATH, etc. etc. to no avail.  Every time I hack/fix one
problem, there is another problem.

I would really like to get a setup so I can do a repeatable build from CVS
to keep current with various updates/bugfixes.  I think this is the intent
of the mono-build-w32.sh script.  Can all of the above be consolidated
into a set of steps that will work and is repeatable?  If by some stroke
of luck I am able to get this to compile on my laptop, I am going to have
to go through this same 2 day process on my desktop trying to get it to
build there.

Is my experience uncommon?  Are others out there able to compile fine on
Windows/Cygwin?  Is there something I am missing?  Isn't there an
automated build process that runs every night and verifies the build works
successfully and nothing is broken on all target platforms?

My setup:
Windows XP Professional SP 1
Cygwin 1.5.5-1 everything installed

I have the correct autotools versions after copying the cygwin devel
versions into /usr/bin.  I corrected the libgc problem by copying gc.dll
to /usr/lib.  I am now getting errors in mono/metadata about icall.c.

I am just frustrated and I am wondering if it is something that I am doing
wrong, or if the build script is broken, or if there is some easy way to
get a 'reference' environment setup.  It seems like others have had
success building Mono on Cygwin with relative ease, so I'd like to
determine what is different about my clean-install environment.