[Mono-list] Mono Runtime 0.30 compile error

Luke Stephenson lstephenson@rogers.com
Tue, 3 Feb 2004 14:17:09 -0500

Thanks, this sort of worked, I then got another missing header, insel.h or
similar... after running make separately in some of the sub-directories I
managed to get it to complete the make install

Now to get mod-mono working :)


-----Original Message-----
From: mono-list-admin@lists.ximian.com
[mailto:mono-list-admin@lists.ximian.com] On Behalf Of Rodolfo Campero
Sent: Tuesday, February 03, 2004 7:10 AM
To: lstephenson@rogers.com; mono-list@lists.ximian.com
Subject: RE: [Mono-list] Mono Runtime 0.30 compile error

I had a similar problem in the past, after I reinstalled my OS, and was 
because I forgot to add /usr/local/lib to the load library path.
Are you sure that libicui18n can be found in the paths declared in 
LD_LIBRARY_PATH or /etc/ld.config?
I hope this helps.

>From: "Luke Stephenson" <lstephenson@rogers.com>
>To: <mono-list@lists.ximian.com>
>Subject: [Mono-list] Mono Runtime 0.30 compile error
>Date: Tue, 3 Feb 2004 02:49:02 -0500
>I was busy setting up .29, and I had just finished testing out a simple
>helloworld, when I noticed .30 was released.
>So I unroll .29 and remove it completely.
>Download .30.
>Configure worked perfectly, detecting ICU, etc.
>However when trying to make I receive:
>	Making all in mini
>	make[3]: Entering directory `/root/program_dls/mono-0.30/mono/mini'
>	./genmdesc ./cpu-pentium.md cpu-pentium.h pentium_desc
>	./genmdesc: error while loading shared libraries: libicui18n.so.26:
>cannot open shared object file: No such file 	or directory
>	make[3]: *** [cpu-pentium.h] Error 127
>After some searching, it looks like there was a common related problem last
>spring/summer surrounding this, and I was wondering if someone could help 
>Thanks a lot,
>Mono-list maillist  -  Mono-list@lists.ximian.com

MSN 8 with e-mail virus protection service: 2 months FREE* 

Mono-list maillist  -  Mono-list@lists.ximian.com