[Mono-list] Debian apache2 mod_mono apxs bug/problem

Michael stuff@dustsmoke.com
Mon, 20 Dec 2004 00:47:36 -0700 (MST)

> Does anybody know what we can do to get around this? I would like to use
> mono on debian's prefork'd apache2 under sarge.
> make install
> ......................................
> Making install in src
> make[1]: Entering directory `/usr/local/src/mod_mono-1.0.5/src'
> mkdir -p -- . "/usr/lib/apache2/modules"
> /usr/bin/apxs2 -S LIBEXECDIR="/usr/lib/apache2/modules" -S
> PREFIX="/usr/local" -i -n mono mod_mono.la
> apxs:Error: no config variable PREFIX
> Usage: apxs -g [-S <var>=<val>] -n <modname>
>        apxs -q [-S <var>=<val>] <query> ...
>        apxs -c [-S <var>=<val>] [-o <dsofile>] [-D <name>[=<value>]]
>                [-I <incdir>] [-L <libdir>] [-l <libname>] [-Wc,<flags>]
>                [-Wl,<flags>] [-p] <files> ...
>        apxs -i [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
>        apxs -e [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
> make[1]: *** [install] Error 1
> make[1]: Leaving directory `/usr/local/src/mod_mono-1.0.5/src'
> make: *** [install-recursive] Error 1
> ............................................
> I didn't have these problems with FC2's Apache. I was sort of waiting
> around for the packages to start staying up to date or actually existing
> in the debian sid/sarge repo's but have realized that is a lost cause.
> Thus I must build this stuff from source I guess. Besides, last time I
> tried pre-builts it always demanded all kinds of X stuff to be installed.
> Why would a server have something like that on it?
> (On a side note, has that since changed regaurding the deps of core
> packages for ASP.NET and systems without an X enviroment?)
> -Michael

Ok, so I got around that by editing src/Makefile


-i -n mono mod_mono.la


$(APXS) -S LIBEXECDIR="$(DESTDIR)$(APXS_LIBEXECDIR)" -i -n mono mod_mono.la

But now I can't get the dumb thing to tell me why it is giving me internel
server errors.

I have given it and verified the paths it needs...... And tried in every
combination of those 4 options, all I know is it needs the
MonoApplicationsConfigDir and MonoServerPath because the apache log tells
me so..... After that it just gives me the internet server error instead
of service temporary univaliable...

(mono, xsp and mod_mono built with --prefix=/usr/local)

LoadModule mono_module /usr/lib/apache2/modules/mod_mono.so

MonoExecutablePath "/usr/local/bin/mono"
MonoServerPath "/usr/local/lib/mono/1.0/mod-mono-server.exe"
MonoApplicationsConfigDir "/etc/apache2/mod-mono-applications"
MonoPath "/usr/local/bin:/usr/local/lib/mono/1.0"

example of a mono application (www.myhost.com.webapp)


I have also went bare minimum and did the example demo configuration
without the vhost xml files... No difference.

anybody have any clue why it will no longer log any errors into the apache
error log? I am blind without anything telling me why it isn't working.
And an identical configuration on a fedora box works fine. Already checked
for typo's.

Anybody got any ideas at all?