[Mono-list] mod_mono: connect error

dmclaughlin@mindspring.com dmclaughlin@mindspring.com
Tue, 31 Aug 2004 12:29:35 -0400 (GMT-04:00)

I am having problems with mod-mono-server on Slackware 10 running Apache 1.3.31. I installed and compiled mono, xsp and mod_mono without error. The only thing I did out of the ordinary is to set the prefix for all three installations to /usr/local instead of /usr.

Other than the installation prefix issue, I have followed the instructions in INSTALL to the letter. I have these lines in my httpd.conf file:

LoadModule mono_module        libexec/libmod_mono.so
AddModule mod_mono.c

Alias /demo "/usr/local/share/doc/xsp/test"
MonoApplications "/demo:/usr/local/share/doc/xsp/test"
<Directory /usr/local/share/doc/xsp/test>
	SetHandler mono
	<IfModule mod_dir.c>
		DirectoryIndex index.aspx

(libmod_mono.so is definitely in /usr/local/apache/libexec/libmod_mono.so)

When I run the demo pages with xsp, they work fine. However, when I run them in Apache, I get the following in the error_log:

	[error] (13)Permission denied: mod_mono: connect error (Permission denied). File: /tmp/mod_mono_server

I have successfully set up mod-mono-server and Apache 1.3.31 with the 1.0 release of mono. It is with the 1.0.1 release that I have been having these problems.

I am stumped. Thank you in advance for any help you can offer!