[Mono-list] asp.net application fails with mono 1.0.1

Barbara Plank, Idealnet barbara@idealnet.com
Tue, 17 Aug 2004 08:49:37 +0200

Hi all,

I've a small sample application which was working on Mono 1.0. A few days
ago I updated mono to the new version 1.0.1 (through red-carpet). The update
was successful. 

But now, when I try to run the application (keeping all configurations the
same, which means the httpd.config is still the same and not touching the
applications --- it is still all the same) I get the following error:

System.IO.IOException: Read failure ---> System.Net.Sockets.SocketException:
Operation on non-blocking socket would block in <0x0006b>
in <0x000c3> System.Net.Sockets.Socket:Receive
in <0x000ed> System.Net.Sockets.NetworkStream:Read (byte[],int,int)
--- End of inner exception stack trace ---
in <0x00131> System.Net.Sockets.NetworkStream:Read (byte[],int,int) in
<0x000ad> System.IO.BinaryReader:FillBuffer (int) in <0x00013>
System.IO.BinaryReader:ReadInt32 () in <0x00024>
Mono.ASPNET.ModMonoRequest:ReadString () in <0x00050> (wrapper
remoting-invoke-with-check) Mono.ASPNET.ModMonoRequest:ReadString () in
<0x001a5> Mono.ASPNET.ModMonoRequest:GetInitialData () in <0x0004f> (wrapper
remoting-invoke-with-check) Mono.ASPNET.ModMonoRequest:GetInitialData () in
<0x000ef> Mono.ASPNET.ModMonoRequest:.ctor
in <0x00056> (wrapper remoting-invoke-with-check)
Mono.ASPNET.ModMonoRequest:.ctor (System.Net.Sockets.NetworkStream)
in <0x00034> Mono.ASPNET.RequestReader:.ctor
in <0x00077> Mono.ASPNET.ModMonoWorker:Run (object)

I had no problem running in with Mono 1.0. May it be a bug? Has somebody
else tested Mono 1.0.1 yet? When I try with other applications I get the
same error

Thanks for any hint,

When I try to run the same application on another machine which has still
mono 1.0 installed, it works fine.