[Mono-list] XSP 0.11 problem

Andrew Arnott AndrewArnott@byu.edu
Wed, 21 Apr 2004 10:37:22 -0600

I had a root directory and the /mono virtual directory set up
previously, but since upgrading to mod_mono 0.8 and XSP 0.11, I have
noticed several issues:

1. The mod-mono-server.exe is compiled to /usr/local/bin rather than
/usr/bin.  According to the web page I downloaded it from, /usr/bin
should have been its location.
2. Apache 2.0.49 failed to start mod-mono-server.exe automatically.
Maybe due to its non-standard location?  But I moved mod-mono-server.exe
to /usr/bin and it still did not get loaded by Apache automatically.
3. By starting mod-mono-server.exe manually on the command line, I've
managed to get /mono to work (the standard xsp/test directory), but my
root web which is an ASPX set does not load up.  Instead, I get the
"Service Temporarily Unavailable" error, which seems standard for when
the mod-mono-server.exe is not loaded.
4. No apache configuration files appears to have been automatically
modified, as the web page said they would be.

My configuration is:
1. SuSE 9.0
2. Apache 2.0.x is installed in the system by SuSE, and its
configuration files are in /etc/apache2, but I am NOT using this Apache.
3. Apache 2.0.49 is installed under my home directory,
/home/andrew/apache2, on port 8080.  I have modified the configuration
files within that Apache to the point where it worked with the old XSP
and mod_mono, and then I tried to bring them up to date with the
instructions on the web page, but the problems above occurred.
4. I have tried running these under root and under my user account. =20

Thanks for your help.