[Mono-list] Instructions for Windows install?

Daniel Morgan danielmorgan@verizon.net
Sat, 17 Apr 2004 00:28:45 -0400

If you are running it in the MS DOS shell, make sure mono "is not in" your

You run mono like: mono
or mcs like: mcs

Also, if you are running it in Cygwin bash shell, make sure you put mono and
msc "in" your PATH.  This PATH in cygwin can be set editing your
.bash_profile to include mono in your PATH.
To run mono: mono.bat
To run mcs: mcs.bat

The reasoning behind this (I think):
If mono.exe and mcs.exe are in your PATH, then they get run BEFORE mono.bat
and mcs.bat

My personal experience has shown not to install stuff to a directory with
spaces in the file name, such as, "Program Files".
At the company I work at, the company policy requires that any network
shares and folders should not contain any spaces.

-----Original Message-----
From: mono-list-admin@lists.ximian.com
[mailto:mono-list-admin@lists.ximian.com]On Behalf Of Kevin Goodsell
Sent: Friday, April 16, 2004 11:57 PM
To: mono-list
Subject: [Mono-list] Instructions for Windows install?

I downloaded the pre-built Windows installer. Aside from my permissions
problem, that ran fine and installed without incident.

But I can't find anything at all on what to do next. The path was not
set up, so I added the /bin directory manually, guessing that it was the
right thing to do. I tried to test this by running 'mcs' (in a Cygwin
Bash shell, and also in a DOS shell) and got the following error:

"The application failed to initialize properly (0xc0000135). Click on OK
to terminate the application."

This isn't exactly a surprise, considering mcs.exe is supposed to be a
.NET executable, right? I notice there's a shell script called 'mcs',
which kind of looks like it's supposed to run mcs.exe using mono, but 1)
it has strange paths, 2) it's a Bourne shell script, this is Windows,
and 3) as far as I can tell the .exe (having the same name, but with the
.exe extension) will always run first, so I don't even know if I can run
the script. Here's the entire contents:

c:/b/install/bin/mono c:/b/install/bin/mcs.exe "$@"

My installation path is "C:\Program Files\Mono-0.31", so I don't know
where the /b/install stuff comes from.

I also tried to just run 'mono'. That gives the following error:

"This application has failed to start because icuin26.dll was not found.
Re-installing the application may fix this problem."

Can anyone clue me in on what to do or where to find information about
how to complete a Windows install?



Mono-list maillist  -  Mono-list@lists.ximian.com