[Mono-list] Starting processes with parameters from Mono 0.31 and mono-

Vadim B. Guzev vguzev@yandex.ru
Thu, 1 Apr 2004 17:36:51 +0400


I've seen somewhere in the list before (but I can't find this letter now,
when I really need it :( ) that someone had problems with starting processes
with parameters from Mono 0.31. Was this problem solved?

I have the same problem now, as even the following simple application
doesn't work anymore in Mono 0.31 (it worked correctly in Mono 0.29):
using System;
using System.Diagnostics;

class ProcessStart {
 static void Main(string[] args) {
  Console.Out.WriteLine("Trying to start: 'mono --version'");
  ProcessStartInfo psi = new ProcessStartInfo();
  psi.FileName = "mono";
  psi.Arguments = "--version";

  Process p = new Process();
  p.Start( psi );


Instead of printing the version - it prints now the help for parameters
I've checked and the specified parameters ("--version") are not passed to
the target program ("mono") at all... Is there any workaround for this

I've tried the daily package mono-, but it seems to
me, that method Process.Start doesn't work at all in this version ... even
without parameters... :(
What's happening?

Best regards,
Vadim B. Guzev