[Mono-list] Gtk#+Mono = Windows Crazy? or Wrong Version

Leandro André Zis lezis@st.com.br
Tue, 07 Oct 2003 09:59:16 -0300

It seems that the gtk-runtime doesn't install libglade with it. So the 
glade# will not work.

Leandro André Zis

Pablo Fischer wrote:

>I need to install Mono and Gtk# in 25 computers running Windows (Im
>going to develop an app for the university in Linux and run it in
>Im installing this packages in this order:
>* .NET FrameWork
>* Mono-.28 (I tried with .25 and I have the same error)
>* Gtk#-10, but the stable version (like 3.xx MB), it contains the
>Now Im testing with a simple app created with glade-sharp, gtk-sharp,
>its a simple button that says: Bye World. But Everytime I try to run it
>it crashes, giving me this error:
>FAiled to load function gtksharp_glade_xml_get_filename from
>gtksharpglue (this error appers twice)
>Unhandled Exception: System.TypeInitializationException: An exception
>was thrown by the type initializer for
>Gtk.Application--->System.NullReferenceException: A null value was found
>where an object instance was required.
>I compiled this in my linux, running 
>Mono .26
>gnome, gtk, glib, gtk-sharp-glue with .8-1
>Mono-list maillist  -  Mono-list@lists.ximian.com