[Mono-list] Problem build with snapshoot today

Met @ Uber met@uberstats.com
Mon, 03 Nov 2003 13:21:22 -0500

On Fri, 2003-10-31 at 02:28, Mohammad DAMT wrote:
> On Rab, 2003-10-29 at 17:09, Jackson Harper wrote:
> > There appears to be a problem with the monocharge's, possibly from being
> > built with an old mcs. Try using a daily. Hopefully we can get this
> > issue resolved tommorow.
> still doesn't work with current CVS, rh 7.3, rh 9
> but I was able to compile with some efforts:
> 0. manually copy corlib.dll from monocharge to mcs/class/lib/ just after
> this error shows up
> 1. go to problematic directory, run make there
> 2. go to mcs/class, run make
> repeat step 0 - 2 if the error shows up in the other directory
> 3. continue make fullbuild in mono/

I checked out the source from CVS today and tried to update my  Mono/Mcs
install as described by the README.  I got the error that was described
above and copied over the corlib.dll from monocharge which fixed that
error (thanks).  I then followed the directions down to "make fullbuild"
in mono which generated some errors.  I can't see how to fix these
errors via the directions above.  For starters, the errors would full
quite a few pages printed so while scanning them the biggest piece comes
from mono/metadata and it ends at mcs/class/System.Drawing (I see some
stuff about Cairo).  But honestly I'm not sure how to diagnose this.

Any help would be greatly appreciated.

~ Matthew