[Mono-list] IBuySpy on FreeBSD

Erik Nordstrom Andersen erik@erik-n-andersen.dk
Wed, 28 May 2003 09:17:47 +0200


Newbie alert! Following a discussion on gotmono.com:
I'm trying to get IBuySpy running under FreeBSD, to try out both asp.net =
unix. I've installed boehm-gc and mono from ports, and tried to install X=

I downloaded XSP 0.4 source from go-mono.com, untarred and tried to insta=
ll as=20
root. I get the following error message:=20

> yada# make=20
> make -C test=20
> make: don't know how to make %.cs. Stop=20
> *** Error code 2=20
> Stop in /usr/home/erik/xsp-0.4.=20
> yada#=20

mcs and mono seem to be working (compiled and ran a couple of C# test=20
programs). What am I doing wrong?

Using FreeBSD 5.0, mono 0.24, boehm 6.1 and xsp 0.4.

I tried using the mod_mono / apache2 combination instead, but got stuck i=
n the=20
install notes here:

> The ModMono.cs file is located in the src/ directory=20
> This is the command to build ModMono.dll:=20
> =20
> make -f makedll.mak=20
=2E.. but there is no ModMono.cs anywhere on my system, and make -f maked=

> yada# make -f makedll.mak
> Unknown modifier ','
> mcs /debug+ /debug:full /nologo ) /target:library /out:ModMono.dll
> Syntax error: ")" unexpected
> *** Error code 2
> Stop in /usr/home/erik/mod_mono-0.3/src.
> yada#

This was with apache 2.0.45 from ports, and mod_mono 0.3.7 from=20

Kind regards,