[Mono-list] wine monostub error -> mono_domain_assembly_open

Alexandre Pigolkine pigolkine@gmx.de
17 May 2003 23:03:39 +0200


The question is not simple.

I tried today to run some SWF apps with current Mono CVS and
had no success :(

(In general) monostub is old method to run SWF applications with 
Mono on Linux. May be you would like to have a look at new approach
to do this :

Regarding gc:
I would recommend to compile and install libgc module from Mono CVS
before configuring Mono. Then, configure for mono should find gc.h.

Monoold.pc is identical to Mono.pc except one thing:
it refers to liboldmono.so instead of libmono.so. You can
create it from Mono.pc by changing the Libs line to

Libs: -L${libdir} -loldmono -lpthread -lm

You need to rebuild monostub in System.Windows.Forms after this change.

To run application use
runwine <app_name_here>.exe


On Fri, 2003-05-16 at 23:46, "Ing. Ernesto Pérez Estévez" wrote:
> Hi and sorry if this is a simple question.
> I have spent two days trying to setup mono to work with 
> System.Windows.Forms without success
> I'm following this recipe:
> http://monoevo.sourceforge.net/mono/SWF.txt
> And using the latest stable sources from mono, wine and gc
> I will describe what happens when I follow SWF.txt steps:
> 1 and 2- Wine installs ok, no problem at all. BTW I run wine under user: 
> wine and I'm able to open notepad, etc.
> 3- gc installs ok
> 4- ok
> At this point I realized that to acomplish point 5 I've to compile and 
> install mono. Ok, I did it
> ./configure --with-gc=no
> make
> and I got some errors regarding gc_typed.h and gc.h
> (oh, yes: I tried ./configure --without-gc as well)
> Finally I copied from ~/gc/include/gc.h and gc_typed.h to /usr/local/include
> I guess the problem is here but didn't find a way to overcome the 
> problem with gc.h
> I also got a message about -lgc not found. I removed all references to 
> -lgc in the makefiles and it finally compiled ok.
> 5- all paths were ok.
> I typed make in that directory and got an error regarding it couldn't 
> finr mono.pc
> PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
> make again and no problems. It compiled.
> (I don't know if the make should be issued from the mcs root or from 
> mcs/classes/System.Windows.Forms/System.Windows.Forms)
> 6- ok,
> monowinehooks.so  and runwine  were copied to /usr/local/bin/mono
> 7- added ok the lines.
> 8- su - wine
> wine monostub
> and I got:
> Could not stat /mnt/fd0 (No such file or directory), ignoring drive A:
> Could not stat /cdrom (No such file or directory), ignoring drive D:
> wine: cannot open builtin library for 'C:\WINDOWS\SYSTEM\monostub.exe': /usr/local/lib/wine/monostub.exe.so: undefined symbol: mono_domain_assembly_open
> I have tried installing mono via rpm with no success.
> I compiled everything in a recently installed machine (no mono from rpm nor nothing) and no success.
> I really don't know what's happening. And I'm interested in trying to run a simple app compiled in .NET windows.