[Mono-list] build problem with Mono 0.24

Chris Ball chris@void.printf.net
Thu, 08 May 2003 12:52:09 +0100


>> On 07 May 2003 20:49:27, Jim Kerr <jbkerr@sonic.net> said:

   > Hello All, I can't build with the 0.24 release. When I run
   > configure, it inserts this little complaint into config.h:

   >  #error configure failed to discover size of unix socket path

I had the same problem with 0.24 myself this morning and was kindly
helped by Miguel on IRC, who remembered solving the same problem by
reinstalling libgc.  The same fix worked for me, on RH9.

Is Jaime's mono-common-problems file still maintained?  The link to it
from http://go-mono.com/faq.html#problems (and from doc/faq) is 404ing.
Perhaps mono-common-problems itself could be added into the mono tree,
under doc/?  (I'm happy to provide a patch for this case once I know
which file to patch.  :)

- Chris.
$a="printf.net";  Chris Ball | chris@void.$a | www.$a | finger: chris@$a
|    "I like how, in software, 'gracefully' means not exploding and
|    destroying everything." - gale:pub.comp.configure, 2003-04-29.