[Mono-list] Mono build problem. Please Help

Daniel Morgan danmorg@sc.rr.com
Wed, 19 Mar 2003 18:11:57 -0500

Here's an idea...

Download the Mono 0.23 Windows Installer...

Make sure you have no Mono/mcs stuff still lying around somewhere...

Install it somewhere....

Modify the mono/doc/mono-build-w32.sh script to not download and not to
the gc.

The modified line is 148.
install_package libgc-dev.zip lib/gc.dll gc-dev

Comment it out with a # (pound) in front.
#install_package libgc-dev.zip lib/gc.dll gc-dev

Now, try running the mono-build-w32.sh script again.

-----Original Message-----
From: mono-list-admin@lists.ximian.com
[mailto:mono-list-admin@lists.ximian.com]On Behalf Of John BouAntoun
Sent: Wednesday, March 19, 2003 5:49 PM
To: Stefan Kyntchev; mono-list@lists.ximian.com
Subject: RE: [Mono-list] Mono build problem. Please Help

not sure what it is, but I have been having this problem for the last month
or so.

Apparently it has something to do with the Cygwin setup being crap.

It would be really nice if some one could make an image of all the required
cygwin packages required to build mono on cygwin, so that newbies could go
and download all the cygwin packages, do a local install and then get mono
from cvs and build it using mono-build-w32.sh

John  BouAntoun
-----Original Message-----
From: Stefan Kyntchev [mailto:skyntchev@cardinalsolutions.com]
Sent: Wednesday, 19 March 2003 8:25 AM
To: mono-list@lists.ximian.com
Subject: [Mono-list] Mono build problem. Please Help

I am trying to build mono on my XP box, running cygwin.

I downloaded and installed the latest COMPLETE installation of cygwin. When
trying to build mono I got the following error:

checking whether to build static libraries... yes
creating libtool
checking for sys/filio.h... no
checking for sys/sockio.h... no
checking for netdb.h... no
checking for utime.h... no
checking for semaphore.h... no
checking for sys/un.h... no
checking for elf.h... no
checking for wchar.h... yes
checking size of void *... 4
checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 1.3.11... yes
BASE_DEPENDENCIES_CFLAGS... -I/usr/stefan/install/include/glib-2.0 -I/u
BASE_DEPENDENCIES_LIBS... -L/usr/stefan/install/lib -lglib-2.0 -lintl -
checking for gc.h... no
checking for gc/gc.h... no
checking for GC_malloc in -lgc... yes
configure: error: Found libgc but not its header files! You may need to
them by hand.

I tried installing on XP and  Win 2000, with the same result.

Does anyone know how to get around this issue?