[Mono-list] [PATCH] running NAnt-0.6 on linux

Jeroen Janssen japj@xs4all.nl
Wed, 01 Jan 2003 14:51:47 +0100

Artur Karazniewicz wrote:

> Hello,
> Here is a patch allows use NAnt-0.6 (mono/mcs/nant) on linux with mono.
> I tested it with mono class library and looks like it works. 


I tried this patch, but I can't seem to get it to work.
(Note that I'm running mono 0.17, not the latest CVS, so maybe that is 
my problem?)

Anyway, I get:
japj@debian:~/cvs/mcs/nant$ mono --debug ./Nant.exe
Buildfile: /home/japj/cvs/mcs/nant/NAnt.build
   [tstamp] 01/01/2003 13:46:12

System.InvalidCastException: Cannot cast from source type to destination 
in [0x0007e] (at /home/japj/cvs/mcs/nant/./src/Task.cs:158) 00 
SourceForge.NAnt.Task:AutoExpandAttributes ()
in [0x00000] (at /home/japj/cvs/mcs/nant/./src/Task.cs:182) 00 
SourceForge.NAnt.Task:Execute ()
in [0x001c1] (at /home/japj/cvs/mcs/nant/./src/Project.cs:254) 00 
SourceForge.NAnt.Project:Initialize (System.Xml.XmlDocument)
in [0x00102] (at /home/japj/cvs/mcs/nant/./src/Project.cs:159) 00 
SourceForge.NAnt.Project:Run ()

Try `Nant -help' for more information.

And line 158 os Task.cs is:
    foreach (ValidatorAttribute validator in validators) {

Since you changed  line 157, I'm assuming you had a similar problem, but 
it doesn't seem to be solved yet?

Best regards,

Jeroen Janssen