[Mono-list] Problems in CVS compile

Deepak nallan_deepak@yahoo.com
Thu, 20 Feb 2003 09:58:02 -0800 (PST)

Hi All,

I used the rpm version of mono-0.19 till now. I wanted
to try out the cvs version and so I checked out the

I tried to build them over the mono-0.19 install but
in a different directory(ie /usr/local). But they dont
seem to compile at all. Atleast the mono module does
but the mcs module throws an error saying 


* (/usr/bin/mcs.exe:848): WARNING **: cant resolve
internal call to
"System.AppDomain::InternalSetDomainByID(int)" (tested
without signature also)

Your mono runtime and corlib are out of sync.
When you update one from cvs you need to update,
compile and install
the other too.
Do not report this as a bug unless you're sure you
have updated correctly:
you probably have a broken mono install.
If you see other errors or faults after this message
they are probably related
and you need to fix your mono install first.

As stated I checked out both the modules(ie mono and
mcs) at the same time. So what might be the problem
now. Any mistakes by me in the steps I followed. Do I
have to set any environment variables or change some

I even tried the mono-build.sh script and even that
failed for a different reason.

Could someone help me out.



Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more