[Mono-list] Starting xsp at bootup

Fawad Halim fawad@fawad.net
Sun, 02 Feb 2003 18:38:40 -0600

  I am trying start the XSP server.exe at system startup. To do that, 
I've written a small sysv init script. I've got a line like:

     su ${RUNAS} -c "cd ${XSPHOME};${MONO} server.exe >server.log 2>&1" &

in it, where ${XSPHOME} is the xsp/test directory and ${MONO} is 
/usr/local/bin/mono. ${RUNAS} is the user I'm trying to run the app as. 
When I run xsp with the script above, I get the error:


System.Web.HttpException:  ---> System.IO.FileNotFoundException: File 
'tmp1323315300.dll' not found.
in (unmanaged) /usr/local/bin/mono(mono_raise_exception+0x20) [0x80bbc56]
in (unmanaged) 
in <0x00101> 00 System.Web.Compilation.GlobalAsaxCompiler:GetCompiledType ()
in <0x000e6> 00 
in <0x0002c> 00 System.Web.HttpApplicationFactory:CompileApp 
in <0x00048> 00 System.Web.HttpApplicationFactory:InitializeFactory 
in <0x00070> 00 System.Web.HttpApplicationFactory:GetInstance 
in <0x00154> 00 System.Web.HttpRuntime:InternalExecuteRequest 
--- End of inner exception stack trace ---

If I run the same script as the ${RUNAS} user, the site loads up perfectly.

Any suggestions about what I'm doing wrong?