[Mono-list] Strange errors due to ~/.wapi problems

Dag Wieers dag@wieers.com
Mon, 25 Aug 2003 10:59:33 +0200 (CEST)


I've got some strange behavior running a program on one of my machines. On 
another machine it is working properly. When I run the Tray Icon, it 
starts up normally (although it prints WARNING **: Shared memory sanity 
check failed.), but when I click on a menu-item that normally would invoke 
an external command I get:

	[dag@emyn dag]$ proxy-applet

	** (/usr/bin/proxy-applet.exe:10691): WARNING **: Shared memory sanity check failed.

	** (/usr/bin/proxy-applet.exe:10691): WARNING **: Failed to attach shared memory! Falling back to non-shared handles

	(Proxy Applet:10691): GConf-CRITICAL **: file gconf-client.c: line 545 (gconf_client_add_dir): assertion `gconf_valid_key (dirname, NULL)' failed

	Unhandled Exception: System.ComponentModel.Win32Exception: Some sort of w32 error occurred: 3
	in <0x00308> 00 System.Diagnostics.Process:Start_common (System.Diagnostics.ProcessStartInfo,System.Diagnostics.Process)
	in <0x0003d> 00 System.Diagnostics.Process:Start (System.Diagnostics.ProcessStartInfo)
	in <0x0002f> 00 System.Diagnostics.Process:Start (string)
	in <0x0000f> 00 .ProxyTrayIcon:on_mproxy_config_activate (object,System.EventArgs)
	in <0x0005a> 01 System.MulticastDelegate:invoke_void_object_EventArgs (object,System.EventArgs)
	in <0x0012b> 00 GtkSharp.voidObjectSignal:voidObjectCallback (intptr,int)
	in <0x00030> 05 GtkSharp.voidObjectSignal:voidObjectCallback (intptr,int)
	in (unmanaged) 06 Gtk.Application:gtk_main ()
	in <0x00004> 06 Gtk.Application:gtk_main ()
	in <0x00007> 00 Gtk.Application:Run ()
	in <0x00007> 00 Gnome.Program:Run ()
	in <0x000b9> 00 .ProxyTrayIconApplication:Main (string[])


On my other system I only get the GConf-CRITICAL message but the program 
runs fine despite the message.

After removing ~/.wapi everything worked again. I have a feeling that the 
problems might have been caused by a full harddisk but since ~/.wapi 
shouldn't be crucial I wouldn't expect my application to fail because of 

I verified the problem with soapbox, and you can perfectly simulate my 
problem when running the network-applet in a soapbox. (ie. when access to 
~/.wapi is not working correctly)


Kind regards,
--   dag wieers,  dag@wieers.com,  http://dag.wieers.com/   --
[Any errors in spelling, tact or fact are transmission errors]