[Mono-list] Mono and FreeBSD Problem

Philip Chapman pac1085@rochester.rr.com
Wed, 16 Apr 2003 00:35:22 -0400

Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: 7bit

I got Mono 0.23 working, by compiling it by hand.  However, I tried editing the Makefile in /usr/ports/lang/mono to upgrade it to 0.23, changed the distinfo and removed the patches to see if I could get it to build that way, which it did.  But when I went to run the mono 0.23 I built from ports, I get the same error.


On Tue, 15 Apr 2003 23:07:45 -0500
Juli Mallett <jmallett@FreeBSD.org> wrote:

> * De: Philip Chapman <pac1085@rochester.rr.com> [ Data: 2003-04-15 ]
> 	[ Subjecte: [Mono-list] Mono and FreeBSD Problem ]
> > Hello,
> > I've been trying to get Mono to work on FreeBSD 4.8, but keep running into the same problem.  Mono compiles fine, but when I try to compile a program using mono, I get the following error:
> > 
> > bash-2.05b$ mcs test.cs
> > Compilation succeeded
> > 
> > ** ERORR **: file jit.c: line 4099 (mono_get_lmf_addr): should not be reaches
> > aborting...
> > Abort trap (core dumped)
> > 
> > I also tried building Mono on FreeBSD 4.7 and 5.0, but run into the same problems.  This is using FreeBSD ports (/usr/ports/lang/mono).  Any help would be appreciated, as I hope to get Mono running soon.
> Try building from CVS, I have fallen behind in keeping the port up
> to date for a variety of reasons.  If you can tell me that the last
> release or the current CVS code works fine, I'll update the port,
> and Gtk# too.
> Thanx,
> juli (semi-maintainer of mono on freebsd, and all-around slacker).
> -- 
> juli mallett. email: jmallett@freebsd.org; aim: bsdflata; efnet: juli;
> _______________________________________________
> Mono-list maillist  -  Mono-list@lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list

Content-Type: application/pgp-signature

Version: GnuPG v1.2.1 (GNU/Linux)