[Mono-list] Building mono on cygwin (SOLVED, kinda)

Piers Haken piersh@friskit.com
Sat, 30 Mar 2002 14:59:20 -0800

Amazing! I've actually got it to build... (it's doesn't run yet, but
I'll get to that)

I didn't see Tom's document until just now, so I'm feeling pretty stupid
right now, but I guess I have some additions/corrections to what he

1) My first big mistake was that my cygwin mounts were textmode. Ugh. To
change this, I had to reinstall cygwin, choosing the 'unix' option in
setup. I also had to blow away my local CVS repository because CVS
doesn't seem to like the extra '\r's that suddenly appeared in all its
files, and I guess you guys wouldn't appreciate them turning up in all
my diffs ;-)

2) I installed the glib et al. bins/libs into /usr/local as tom
discribes. I actually ended up doing 'mv /usr/local/lib/*.dll
/usr/local/bin', is that bad?

3) I'm not sure if this is necessary, but I changed all the lines in
/usr/local/lib/pkgconfig/*.pc that read:
To read:

4) instead of hacking up the source files as tom describes, I got round
the 'netdb.h' problems by doing what the mono-build-w32.sh script does:

   export CPPFLAGS="$CPPFLAGS -I/usr/local/include"
   export LDFLAGS="$LDFLAGS -I/usr/local/lib"
   export CC="gcc -mno-cygwin"	

This alows the configure script to get the correct value for
HAVE_NETDB_H (since it compiles its test with the -mno-cygwin flag also)

5) './configure --prefix=/usr/local'

6) make clean && make && make install

7) I had to 'mv /usr/local/bin/mcs /usr/local/bin/mcs.sh' because cygwin
wants to execute /usr/local/bin/mcs.exe in preference.

So now I'm getting this error:

[/usr/local/bin]:./mint.exe mcs.exe
The assembly corlib.dll was not found or could not be loaded.
It should have been installed in the `/usr/local/lib' directory.
[/usr/local/bin]:ls -l /usr/local/lib/corlib.dll
-rwxr-xr-x    1 Administ None       761856 Mar 30 14:52

Any ideas?


-----Original Message-----
From: Piers Haken 
Sent: Saturday, March 30, 2002 11:53 AM
To: Dan Nedelko
Cc: Mono List
Subject: RE: [Mono-list] Building mono on cygwin

Yeah, I get the same error when using the mono-build-w32.sh...


-----Original Message-----
From: Dan Nedelko [mailto:dan@genuinemedia.com] 
Sent: Saturday, March 30, 2002 7:14 AM
To: Piers Haken
Cc: Mono List
Subject: Re: [Mono-list] Building mono on cygwin

Your best best for compiling mono is by utilizes Dick's mono-build.sg 
and mono-buils-w32.sh scripts which are located on the website 

It should automate the process for you in a nice clean manner.


Dan Nedelko

Piers Haken wrote:

>Can someone help me to build the runtime on mono?
>I'm not having much luck with the instructions on the site.
>Right now I'm getting the following error:
>gcc -g -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations
>-Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Wshadow 
>-Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -mno-cygwin -o

>pedump.exe -Wl,--export-dynamic ../io-layer/libwapi.a
>../utils/libmonoutils.a -L/usr/local/lib -lglib-1.3 -liconv -lintl 
>-lgmodule-1.3 -lws2_32
>/usr/lib/mingw/libmingw32.a(main.o)(.text+0xaf):main.c: undefined 
>reference to `WinMain@16'
>collect2: ld returned 1 exit status
>Any ideas?
>Mono-list maillist  -  Mono-list@ximian.com

Mono-list maillist  -  Mono-list@ximian.com