[Mono-list] Re: Mono release 0.12 / RH7.3 / segmentation fault

Stewart Allen mono@neuron.com
Sun, 16 Jun 2002 12:11:16 -0400

You can't use the libgc source rpms. get the raw libgc source straight from:


I'm using gc6.1alpha4.tar.gz, but there's a newer snapshot available now.


Christophe VG wrote:
> On Sun, 2002-06-16 at 15:10, Miguel de Icaza wrote:
>>Yes, I did.  I had to download and install the latest libgc (Just do a 
>>google search for "boehm gc", and it will be the first match).  You have to 
>>compile this first, and then mono, and it works just fine. 
>>I also just installed Red Hat 7.3 this week and ran into the same issue. 
> [root@taurus root]# rpm -qa | grep libgc
> libgc6-devel-6.1-1                        <----- brand new
> libgc6-6.1-1                              <----- brand new
> [root@taurus root]# rpm -qa | grep mono 
> mono-0.12_baselabs-20020616               <----- brand new
> [root@taurus root]# mono
> Segmentation fault                        <----- still :-(
> I'm sorry to say, but for me the problem isn't solved ... I downloaded
> the latest libgc6 sources and rebuild the RPMs on RH7.2, then did the
> same for the mono RPMs. They all run happily on RH7.2 ... but installing
> and using them on RH7.3 still segfaults ...
> Conclusion ... I'm still not able to compile the RPMs on RH7.2 and use
> them on RH7.3 :-(
> I'm going to go over the entire process again to double check, but
> unless someone can help me with some debugging hints, I have no real
> clue how to track down this problem.
> I will in the mean time also try to build the RPMs on RH7.3 and see if
> they run on RH7.2 ... that would solve the problem (partially in my
> opinion)
> Christophe