[Mono-list] Bootstrap problems upon bootstrap problems

Dale Peakall dale.peakall@bit-arts.com
Fri, 19 Jul 2002 18:09:32 +0100

Now that mcs and the libraries are compilable on linux I thought I'd have a 
go at updating my install (0.12) and got the latest source from CVS.  Ia 
ttempt to compile mcs (which works), but fails when compiling corelib:

../mcs-tool: creating wrapper mcs
make[1]: Leaving directory `/home/dlp/Mono/mcs/mcs'
make[1]: Entering directory `/home/dlp/Mono/mcs/class'
make[2]: Entering directory `/home/dlp/Mono/mcs/class/corlib'
../../mcs-tool --target library --noconfig -o corlib.dll --unsafe --nostdlib 
mono /usr/local/bin/mcs.exe --target library --noconfig -o corlib.dll 
--unsafe --nostdlib @.response
error CS0518: The predefined type 
`System.Runtime.CompilerServices.IndexerNameAttribute' is not defined or 

So, I tried updating mono and now whatever I try to compile returns the error:

mono /usr/local/bin/mcs.exe --target library --noconfig -o corlib.dll 
--unsafe --nostdlib @.response
Corlib not in sync with this runtime: field `interfaces' mismatch in class 
TypeBuilder (28 != 24)

So, I tried copying my newly built mcs.exe into /usr/local/bin and it makes no

Not got a windows box to bootstrap from so am a little sad atm.  Back to 0.12 
install I guess for me.