[Mono-list] RE: mcs make problems in Redhat 8.0 & Test Suite

Scott Lowe scott@budomail.com
Mon, 16 Dec 2002 11:45:49 +0000

Hi All,

Uh, looks like I was being dumb - I tried to compile again from scratch
and used the instructions on the download page and I got further this 
I didn't have the "install prefix=/usr/local" argument before.

Incidentally, I was using the INSTALL (for mcs and runtime) docs 
with the distribution which are slightly different from the surefire 
on the mono site.

OK, so on to tests. I am still using "make -f makefile.gnu test" to 
build the tests.

Make is failing at:

System.Text/AllTests.cs(25) error CS0103: The name
`UTF8EncodingTest.Suite' could not be found in

So I had a look in mcs-0.17/class/corlib/Test/System.Text/ and yes
UTF8EncodingTest.cs is missing - Is this the correct directory?

Only StringBuilderTest.cs is in that directory, and it is commented out 
of this
directory's AllTests.cs file:

                 public static ITest Suite
                                 TestSuite suite =  new TestSuite();
                                 return suite;

Since ASCIIEncodingTest.cs is also missing, I guess it should be:

                 public static ITest Suite
                                 TestSuite suite =  new TestSuite();
                                 return suite;

I ran make again and got much further, in fact, many tests ran 
until I got blocked at an exception - should I post any more 
information concerning my
problems to the list? Or, should I talk to one of you individually, as 
I could do with
a little coaching :o)