[Mono-list] mint bug

Petru Paler ppetru@ppetru.net
Thu, 27 Sep 2001 23:09:44 +0300

Hello everyone,

I have this program:

// Namespace Declaration
using System;

// Program start class
class NamedWelcome
    // Main begins program execution.
    public static void Main(string[] args)
        // Write to console
        Console.WriteLine("Hello, {0}!", args[0]);
        Console.WriteLine("Welcome to the C# Station Tutorial!");

When I run it with the MS runtime, I get the expected result (command line 
is "wine Welcome.exe"):

Hello, asd!
Welcome to the C# Station Tutorial!

When I run it with mint (from 26-Sep-01 snapshot) I get this:

ppetru@shiva:~/projects/dotnet/tutorial$ mint Welcome.exe asd
Unhandled exception System.NullReferenceException.
#0: 0x00002 in System.IO.StreamWriter::Write ([(nil)] )
#1: 0x00008 in System.IO.TextWriter::Write ([0x807a998] [0x807a898] )
#2: 0x00007 in System.Console::WriteLine ([0x807a998] [0x807a898] )
#3: 0x00008 in .NamedWelcome::Main ([0x8072740] )

My C# knowledge is still inexistent (that's why I was running that program 
:) so I'm posting this in the hope someone know what's happening.