[Mono-list] Configuring and making Mono Runtime

Richard Anthony Hein 935551@ican.net
Mon, 10 Sep 2001 17:27:14 -0400

I just tried that and now I get this error:

rahein@K6 ~/mono
$ ./autogen.sh --prefix=//c/mono
Running libtoolize...
You should add the contents of `/usr/local/share/aclocal/libtool.m4' to
Running aclocal  ...
aclocal: configure.in: 14: macro `AM_PROG_LIBTOOL' not found in library
aclocal: configure.in: 21: macro `AM_PATH_GLIB' not found in library

**Error**: aclocal failed. This may mean that you have not
installed all of the packages you need, or you may need to
set ACLOCAL_FLAGS to include "-I $prefix/share/aclocal"
for the prefix where you installed the packages whose
macros were not found

I am using libtool-1.4.1 - do you think that's the problem?


Richard A. Hein

-----Original Message-----
From: mono-list-admin@ximian.com [mailto:mono-list-admin@ximian.com]On
Behalf Of Bob Smith
Sent: September 10, 2001 5:09 PM
To: Richard Anthony Hein
Cc: mono-list@ximian.com
Subject: Re: [Mono-list] Configuring and making Mono Runtime

/autogen.sh --prefix=//c/mono
make install

On Mon, 10 Sep 2001, Richard Anthony Hein wrote:

> I haven't done this for awhile (and I haven't much of a clue), as I have
> been trying to get my system all set up with Debian Sid, reinstalling
> Windows 2K (registry got screwed), and other stuff that has occupied my
> time.
> The last time I installed the Mono runtime, things worked fine.  Now it
> seems that the instructions on  http://www.go-mono.com/download.html are
> correct.  I added the step of running autoconf before ./configure (as just
> running ./configure first results in a path or file not found error).
> What am I doing wrong or missing here?
> rahein@K6 ~/mono
> $ autoconf
> configure.in:16: warning: AC_TRY_RUN called without default to allow cross
> compi
> ling
> rahein@K6 ~/mono
> $ ls
> AUTHORS  ChangeLog    NEWS    autogen.sh  configure.in  libffi  notes
> status
> CVS      Makefile.am  README  configure   doc           mono    runtime
> ximian
> rahein@K6 ~/mono
> $ ./configure --prefix=//c/mono
> creating cache ./config.cache
> ./configure: 523: Syntax error: word unexpected (expecting ")")
> ThanksE6,
> Richard A. Hein
> _______________________________________________
> Mono-list maillist  -  Mono-list@ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list

Mono-list maillist  -  Mono-list@ximian.com