[Mono-list] build broken in mono

Stefan Maierhofer sm@dhm.at
Fri, 7 Sep 2001 23:06:42 +0200

I checked out the current version of mono  (cvs -z 3 co mono), then I try 
./autogen.sh (this worked for me until about 2 days ago)
But now I get the following:


> ./autogen.sh
**Warning**: I am going to run `configure' with no arguments.
If you wish to pass any to it, please specify them on the
`./autogen.sh' command line.
Running ./configure --enable-maintainer-mode --enable-compile-warnings ...
./autogen.sh: ./configure: No such file or directory


Since many recent postings apply to build problems, maybe it would be a good 
idea for someone familiar with the build environment to post a short "how to 
build mono the right way" ;-) 


On Friday 07 September 2001 11:26, you wrote:
> Build break alert!
> I got the latest update from CVS just now and tried autogen.sh in mono.  It
> fails with this message at the end:
> config.status: error: cannot find input file: mono/monoburg/Makefile.in
> Indeed that file is not there. Not sure that file is supposed to be
> generated or what.  I really need to learn this automake stuff...
> Anyway, FYI.
> Nick D.
> _______________________________________________
> Mono-list maillist  -  Mono-list@ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list