<div dir="ltr">Hello,<div class="gmail_extra"><br><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><br>
I notice that in mono master [2] cecil has been upgraded some weeks<br>
ago to current master of cecil, which is version 0.10.0 Beta.<br>
<br>
I still would prefer if external libraries are not that hard bundled<br>
into Mono, at least not delivered in the rpm.<br>
I am trying to patch the bundled version of Cecil out in my spec file,<br>
but that is quite strange and does not look nice. I think we should<br>
aim for the clear and clean way.<br></blockquote><div><br></div><div>Internal Mono cecil was upgraded but it's not bundled in term on publicly</div><div>available reference. It's only installed into GAC because we need it</div><div>to run mono tools.</div><div><br></div><div>Previous version 0.9.5 was installed also as a reference which I agree</div><div>was a mistake but removing it would be a breaking change.</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
Or should I aim to have two versions of Mono.Cecil on the system?<br></blockquote><div><br></div><div>You can have multiple versions of Cecil installed and as Cecil has</div><div>major breaking changes between minor releases it's probably the only</div><div>option you are left with.</div><div><br></div><div>Marek</div></div></div></div>