[Mono-dev] Exception in XmlSerializer (only with arm cross-compile , x86 no issue)

Ran Shalit ranshalit at gmail.com
Sat Sep 24 06:08:05 UTC 2016

On Sat, Sep 24, 2016 at 5:47 AM, Miguel de Icaza <miguel at microsoft.com> wrote:
> I had copied the assemblies from pc, from /usr/lib/mono , but I lso
>     had to copy /usr/local/etc/mono folders.
>     I wish "make install" had made it all , and sould not require
>     additional build and copying. It would have made life more easier.
>     Even at this point, I still not sure about the exact required steps of
>     copying the "mono" assemblies and /etc folders. I wish it was
>     documented somewhere for other who try to build mono and deploy to
>     some target.
> That should already be the case, I am surprised you had to do this in the first place.

Right, there was in /usr/local/etc a folder 2.0 after "make install
But only after copying 4.0 , 4.5 (from PC) it worked without having
the above exception.
I am not sure why. Are there any steps I missed after doing "make
install" for the target ?


More information about the Mono-devel-list mailing list