[Mono-dev] Problem with mcs build

Cyd Haselton chaselton at gmail.com
Thu Sep 22 21:20:41 UTC 2016

Additional info:

Just to see what would happen…and because I've just about given up hope on
hearing back from anyone on this issue…I navigated to
$(topbuilddir)/mcs/mcs and ran make.  Results were:

make[1]: Entering directory
'/data/data/com.termux/files/pkg/ps/mono-4.7.0/mcs/mcs'         MCS
Got a SIGSEGV while executing native code. This usually
indicates                           a fatal error in the mono runtime or
one of the native libraries                            used by your

On Sep 21, 2016 4:36 PM, "Cyd Haselton" <chaselton at gmail.com> wrote:

While waiting for a response I deleted the build tree, downloaded another
tarball from the site, unpacked  and re-ran 'autogen.sh && make'

The build errored out at the same place, with the same prior warnings.

At this point I'm at a loss. Any input would be welcome.

On Sep 21, 2016 7:10 AM, "Cyd Haselton" <chaselton at gmail.com> wrote:

> Pinging again. Any ideas as to where I should be looking for the problem?
> FYI, while waiting I dumped the help for the bootstrap compiler for clues
> and found this:
> <snip>
> -reference:ALIAS=A   Imports metadata using specified extern alias (short:
> -r)
> -sdk:VERSION         Specifies SDK version of referenced
> assemblies                                              VERSION can be
> one of: 2, 4, 4.5 (default) or a custom value
> <snip>
> The command line right before the two warnings and build failure is this:
> MONO_PATH="./../class/lib/monolite:$MONO_PATH"
> /data/data/com.termux/files/pkg/ps/mono-4.6.0/runtime/mono-wrapper
> ./../class/lib/monolite/basic.exe /codepage:65001 -sdk:4.5 -r:System.dll
> -r:System.Core.dll -r:System.Xml.dll -d:STATIC,NO_SYMBOL_WRITER,NO_AUTHENTICODE
> -d:NET_4_5 -d:MONO -d:BOOTSTRAP_BASIC -nowarn:1699
> -lib:./../class/lib/basic   -target:exe -out:../class/lib/basic/basic.exe
> cs-parser.cs  @mcs.exe.sources
> Should the "-r" params include paths to those files?
> On Sep 20, 2016 1:06 PM, "Cyd Haselton" <chaselton at gmail.com> wrote:
>> Any thoughts?  Or is this another stale build?
>> On Tue, Sep 20, 2016 at 8:47 AM, Cyd Haselton <chaselton at gmail.com>
>> wrote:
>>> Additionally I Googled the warning that appears before the build error:
>>> warning CS8001: SDK path could not be resolved
>>> The first two hits mention that the cause is usually due to a missing
>>> System.Drawing.dll, but it is present in the build tree under
>>> ./external/binary-reference-assemblies/vX.x, where 'X.x' is  2.0, 4.0
>>> and 4.5.
>>> Googling the Unhandled Exception error brings up hits from the Unity
>>> forums and not much else.
>>> On Sep 20, 2016 7:13 AM, "Cyd Haselton" <chaselton at gmail.com> wrote:
>>>> While waiting for a response I ran 'make clean' then 'make V=1 2>&1 |
>>>> tee mono_build_log.'
>>>> I've posted the results here: http://pastebin.com/s3gHQQdg
>>>> On Sep 19, 2016 6:02 PM, "Cyd Haselton" <chaselton at gmail.com> wrote:
>>>>> Should I run make clean and try again? Or is there something wrong
>>>>> with  the mcs/mcs Makefile?
>>>>> On Sep 19, 2016 4:33 PM, "Cyd Haselton" <chaselton at gmail.com> wrote:
>>>>>> Downloaded latest tarball, ran autogen.sh. It failed at the start of
>>>>>> the mcs build because the mono-wrapper, mono and mcs scripts had #!/bin/sh
>>>>>> instead of the correct path.  Fixed that, re-ran make and got the  error
>>>>>> from my first email
>>>>>> Pastebin here: http://pastebin.com/gdAcRKN6
>>>>>> On Sep 19, 2016 2:23 PM, "Cyd Haselton" <chaselton at gmail.com> wrote:
>>>>>>> Er…I *can't* do that because the instructions say that building
>>>>>>> from git assumes mono is installed.
>>>>>>> I'll download the latest tarball…
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.dot.net/pipermail/mono-devel-list/attachments/20160922/898a3a4a/attachment.html>

More information about the Mono-devel-list mailing list