[Mono-dev] Building from Source Fails with mcs: Command not found

cyd chaselton at gmail.com
Wed May 20 19:44:56 UTC 2015

Building mono from downloaded source on an Android device. I ran make
get-monolite-latest and still get the following errors

make[2]: Entering directory `/bld/mono/mono-4.0.0/runtime'
if test -w /bld/mono/mono-4.0.0/mcs; then :; else chmod -R +w
/bld/mono/mono-4.0.0/mcs; fi
cd /bld/mono/mono-4.0.0/mcs && make --no-print-directory -s NO_DIR_CHECK=1
PROFILES='binary_reference_assemblies net_4_5 xbuild_12 xbuild_14 monodroid 
' CC='gcc --sysroot=/usr/gcc-4.9.2/sysroot' all-profiles
make[6]: mcs: Command not found
make[6]: *** [build/deps/basic-profile-check.exe] Error 127
*** The compiler 'mcs' doesn't appear to be usable.
*** Trying the 'monolite' directory.
Illegal instruction
make[8]: *** [build/deps/basic-profile-check.exe] Error 132
*** The contents of your 'monolite' directory may be out-of-date
*** You may want to try 'make get-monolite-latest'

I've found what I think is the mcs executable in runtime/_tmpdir/bin, but
copying it to where the build seems to be looking for it doesn't help.

How do I resolve this?

View this message in context: http://mono.1490590.n4.nabble.com/Building-from-Source-Fails-with-mcs-Command-not-found-tp4666000.html
Sent from the Mono - Dev mailing list archive at Nabble.com.

More information about the Mono-devel-list mailing list