[Mono-dev] Error building mono on x86

Rafael Mueller - Inventti rafael at inventti.com.br
Wed Feb 18 08:42:52 UTC 2015


I forgot to say, but I'm trying to build it as x86 on a x64 machine - the compilation as x64 worked (without the --host)

Compilation on a x86 box also worked.

This problem happens when I compile as x86 on a x64 box.



From: Miguel de Icaza <miguel at xamarin.com>
Sent: Wednesday, February 18, 2015 12:21 AM
To: Rafael Mueller - Inventti
Cc: mono-devel-list at lists.ximian.com
Subject: Re: [Mono-dev] Error building mono on x86


I am not sure why you are passing a --host command line option.   Configure should be able to figure this out on its own.


On Tue, Feb 17, 2015 at 6:29 PM, Rafael Mueller - Inventti <rafael at inventti.com.br<mailto:rafael at inventti.com.br>> wrote:
Hi there,

My (c#) application (compiled on windows, as x86) needs to load a 32 bits library (.so), so I must compile mono as x86, right?

I've downloaded the 3.12 source and configured it with
./configure --host=i386-pc-linux-gnu

But it always fails to compile:
In file included from mono-context.c:8:0:
mono-context.c: In function 'mono_sigctx_to_monoctx':
../../mono/utils/mono-sigcontext.h:144:74: error: 'REG_EAX' undeclared (first use in this function)
  #define UCONTEXT_REG_EAX(ctx) (((ucontext_t*)(ctx))->uc_mcontext.gregs [REG_EAX])

I've tried to add AC_GNU_SOURCE on configure.ac<http://configure.ac> and also compiling with CFLAGS="$CFLAGS -D_GNU_SOURCE" but I still can't compile it.

I'm doing anything wrong? Any other advice to compile it on x86?

I've also tried with mono 3.2.3 and 3.6, without success.

Kind regards,

Mono-devel-list mailing list
Mono-devel-list at lists.ximian.com<mailto:Mono-devel-list at lists.ximian.com>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-devel-list/attachments/20150218/f9d830fe/attachment-0001.html>

More information about the Mono-devel-list mailing list