[Mono-dev] Error building mono on x86

Rafael Mueller - Inventti rafael at inventti.com.br
Tue Feb 17 23:29:48 UTC 2015

Hi there,

My (c#) application (compiled on windows, as x86) needs to load a 32 bits library (.so), so I must compile mono as x86, right?

I've downloaded the 3.12 source and configured it with
./configure --host=i386-pc-linux-gnu

But it always fails to compile:
In file included from mono-context.c:8:0:
mono-context.c: In function 'mono_sigctx_to_monoctx':
../../mono/utils/mono-sigcontext.h:144:74: error: 'REG_EAX' undeclared (first use in this function)
  #define UCONTEXT_REG_EAX(ctx) (((ucontext_t*)(ctx))->uc_mcontext.gregs [REG_EAX])

I've tried to add AC_GNU_SOURCE on configure.ac and also compiling with CFLAGS="$CFLAGS -D_GNU_SOURCE" but I still can't compile it.

I'm doing anything wrong? Any other advice to compile it on x86?

I've also tried with mono 3.2.3 and 3.6, without success.

Kind regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-devel-list/attachments/20150217/613b3aa8/attachment.html>

More information about the Mono-devel-list mailing list