[Mono-dev] Mono 3.10 Threadpool requires remoting??

Chris Tacke ctacke at opennetcf.com
Fri Sep 12 23:08:30 UTC 2014

We have a Mono application that we have been successfully running against Mono 3.2.7 for some time now.  We have built Mono ourselves from the source because we're targeting the i586 architecture.

We're targeting a headless embedded device, so we've tried to remove things that we don't use.  One of those "things" is Remoting support.

I just got done getting 3.10.1 built and moved over to a target and now when I run our app I get a MissingMethodException.  ThreadPool.QueueUserWorkItem seems to be calling into Remoting. What's up with that?

Here's the inner exception and its stack trace:

Unhandled Exception:
System.TypeInitializationException: An exception was thrown by the type initializ er for SolutionFamily.SFTrace ---> System.TypeInitializationException: An excepti on was thrown by the type initializer for OpenNETCF.IoC.RootWorkItem ---> System. MissingMethodException: Cannot find the requested method.
  at (wrapper managed-to-native) System.Runtime.Remoting.RemotingServices:IsTrans parentProxy (object)
  at System.Delegate.IsTransparentProxy () [0x00000] in <filename unknown>:0
  at System.Threading.ThreadPool.QueueUserWorkItem (System.Threading.WaitCallback  callBack, System.Object state) [0x00000] in <filename unknown>:0
  at System.Threading.ThreadPool.QueueUserWorkItem (System.Threading.WaitCallback  callBack) [0x00000] in <filename unknown>:0
  at OpenNETCF.IoC.WorkItem..ctor () [0x00000] in <filename unknown>:0
  at OpenNETCF.IoC.RootWorkItem..cctor () [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---

I can go back and regenerate everything with Remoting support, but I'm wondering why this is getting called at all when it wasn't in 3.2.7.


More information about the Mono-devel-list mailing list