[Mono-dev] Building mono on Windows issues.

Chris Eelmaa chriseelmaa at gmail.com
Wed Oct 15 22:17:09 UTC 2014

Hello all,

I have question regarding building mono on windows,
namely I've tried a lot of times, and had a lot of different
problems(such as missing some dependencies, git converting *.sh files
to CRLF ending and cygwin not being able to interpret them, etc..)

however I've reached now to a point where I can run `make` for a little while,
and then receive the error:

In file included from socket-io.c:30:0:
/usr/i686-pc-mingw32/sys-root/mingw/include/ws2tcpip.h:38:2: error:
#error "ws2tcpip.h is not compatible with winsock.h. Include
winsock2.h instead."
In file included from socket-io.c:30:0:
/usr/i686-pc-mingw32/sys-root/mingw/include/ws2tcpip.h:147:8: error:
redefinition of 'struct ip_mreq'
In file included from

As you can see, winsock.h doesn't play well with ws2tcpip.h. I ran a
grep to look for winsock.h from mono dir, but there's nothing about
that. That file seems to be crawling in from some arbitrary place?!

After that, I tried to compile with DISABLE_SOCKETS, and then I
arrived to this place:

./.libs/libmini.a(libmini_la-debugger-agent.o): In function
/cygdrive/c/GITHUB/mono/mono/mini/debugger-agent.c:1236: undefined
reference to `mono_network_init'

At this point, I have no idea what to do. Is mono master branch
broken, or is it possible to actually build it with Windows from
there? Can anyone confirm? Do I have messed up Windows SDK or
something similiar?


More information about the Mono-devel-list mailing list