[Mono-dev] Hi System.xml.parse error in compiling mono

morteza adi mortezaadi at gmail.com
Thu Jul 17 17:05:46 UTC 2014

I'm getting crazy :)

I removed my cloned source and get a new clone from git repo. nothing
changed, again same problem.
I also tried to make the code in another pc - ubuntu 12.04  I got a new

make[2]: Entering directory `/home/morteza/git/mono/runtime'
if test -w /home/morteza/git/mono/mcs; then :; else chmod -R +w
/home/morteza/git/mono/mcs; fi
cd /home/morteza/git/mono/mcs && make --no-print-directory -s
NO_DIR_CHECK=1 PROFILES='net_2_0 net_3_5 net_4_0 net_4_5 xbuild_12   '
CC='gcc' all-profiles
Bootstrap compiler: Mono C# compiler version
MCS     [secxml/basic] System.dll
System.Security.AccessControl/SemaphoreSecurity.cs(136,35): warning CS0109:
The member
does not hide an inherited member. The new keyword is not required
Mono.Http/NtlmClient.cs(99,54): error CS1502: The best overloaded method
match for `Mono.Security.Protocol.Ntlm.Type3Message.Type3Message(byte[])'
has some invalid arguments
(Location of the symbol related to previous error)
Mono.Http/NtlmClient.cs(99,54): error CS1503: Argument `#1' cannot convert
`Mono.Security.Protocol.Ntlm.Type2Message' expression to type `byte[]'
Compilation failed: 2 error(s), 1 warnings
make[9]: *** [../../class/lib/basic/secxml/System.dll] Error 1
make[8]: *** [../../class/lib/basic/secxml/System.dll] Error 2
make[7]: *** [do-all] Error 2
make[6]: *** [all-recursive] Error 1
make[5]: *** [all-recursive] Error 1
make[4]: *** [profile-do--basic--all] Error 2
make[3]: *** [profiles-do--all] Error 2
make[2]: *** [all-local] Error 2
make[2]: Leaving directory `/home/morteza/git/mono/runtime'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/morteza/git/mono'
make: *** [all] Error 2

I wonder how the same code gets built and installed in my virtual ubuntu

On Wed, Jul 16, 2014 at 9:51 PM, Marek Safar <marek.safar at gmail.com> wrote:

> Hello,
> No i didn't build in parallel. just a simple make command with no
>> parameter.
>> when i ran the Make command for the first time i got an error said Perl
>> XML:Parser wasn't installed.
>> so i installed XML::Parser by apt-get libexpat1-dev
>> then  i ran into this error.
> That's probably it. Try to clean your code and rebuild again.
> Marek
> On Wed, Jul 16, 2014 at 8:26 PM, Marek Safar <marek.safar at gmail.com>
>> wrote:
>>> Hello,
>>>> *I successfully make & install the mono code in ubuntu 12.04*
>>>> *when i do the same steps in ubuntu 14.04 i get this error*
>>>> Bootstrap compiler: Mono C# compiler version
>>>> MCS     [build] System.Xml.dll
>>>> System.Xml.XPath/Parser.jay(12,0): error CS1525: Unexpected symbol
>>>> `using'
>>> This is weird error. Did you try to build in parallel ? Also showing
>>> what is actually in file System.Xml.XPath/Parser.jay around reports lines
>>> would help too.
>>> Marek
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-devel-list/attachments/20140717/ab50d768/attachment.html>

More information about the Mono-devel-list mailing list