[Mono-dev] Hi System.xml.parse error in compiling mono

morteza adi mortezaadi at gmail.com
Wed Jul 16 16:58:55 UTC 2014

No i didn't build in parallel. just a simple make command with no parameter.

when i ran the Make command for the first time i got an error said Perl
XML:Parser wasn't installed.
so i installed XML::Parser by apt-get libexpat1-dev

then  i ran into this error.

the same code successfully gets build and install in my virtual machine
(ubuntu 12.04)

codes are from mono master github repository with no change at all!

here is my parser code

i really new in mono and c/c++ and i don't know what to do :(

On Wed, Jul 16, 2014 at 8:26 PM, Marek Safar <marek.safar at gmail.com> wrote:

> Hello,
>> *I successfully make & install the mono code in ubuntu 12.04*
>> *when i do the same steps in ubuntu 14.04 i get this error*
>> Bootstrap compiler: Mono C# compiler version
>> MCS     [build] System.Xml.dll
>> System.Xml.XPath/Parser.jay(12,0): error CS1525: Unexpected symbol `using'
> This is weird error. Did you try to build in parallel ? Also showing what
> is actually in file System.Xml.XPath/Parser.jay around reports lines would
> help too.
> Marek
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-devel-list/attachments/20140716/12b390f0/attachment.html>

More information about the Mono-devel-list mailing list