[Mono-dev] Status of http://wrench.mono-project.com

Grüninger, Andreas (LGL Extern) Andreas.Grueninger at lgl.bwl.de
Wed Jan 15 10:39:33 UTC 2014

There are no builds of mono-master since 2013/12/09 for linux (debian, opensuse, x86/x64).

The disk of the build system seems to be full.


Is there a chance to get the current status of failing tests?

I would really like to compare the status of my changes for solaris/openindiana.






Von: Grüninger, Andreas (LGL Extern) 
Gesendet: Dienstag, 14. Januar 2014 09:45
An: 'Alan'; 'Andrés G. Aragoneses'
Cc: 'mono-devel-list'
Betreff: AW: [Mono-dev] mono-2.11.4 on Solaris 11.1


I find 3 of my failing tests in the outputs of build systems. They are known but not solved. 

And only one of them occurs  sometimes in mac os.

1) MonoTests.System.Globalization.CultureInfoTest.DefaultThreadCurrentCulture :   #6

  Expected: <fr-FR>

  But was:  <>

Sometimes the error disappears, if the test is repeated.


The build server has problems: disk full, see here:  http://wrench.mono-project.com/Wrench/WebServices/Download.aspx?workfile_id=2786814

Since 2013/12/09 all  builds for the linux x86/x64 environment are queued.






Von: Grüninger, Andreas (LGL Extern) 
Gesendet: Montag, 13. Januar 2014 11:18
An: 'Alan'; Andrés G. Aragoneses
Cc: mono-devel-list
Betreff: AW: [Mono-dev] mono-2.11.4 on Solaris 11.1


I started with the master and got a lot of sigsegv.

So I tried first an older version and thought the last release of 2.* would be good choice.


Yesterday  I applied all patches to the master and compiled it.

I have 7  failing tests.

4 of them have the same problem. The return of Culture.InvariantCulture is wrong, UseUserOverride is true and should be false.

All other cultures are correct.

Tests in:  mcs/class/corlib/Test/System.Globalization/CultureInfoTest.cs

Source in: mcs/class/corlib/System.Globalization/CultureInfo.cs


Any ideas?




Von: mono-devel-list-bounces at lists.ximian.com [mailto:mono-devel-list-bounces at lists.ximian.com] Im Auftrag von Alan
Gesendet: Montag, 13. Januar 2014 11:10
An: Andrés G. Aragoneses
Cc: mono-devel-list
Betreff: Re: [Mono-dev] mono-2.11.4 on Solaris 11.1


Before submitting pull requests you should check to see if the issue still exists in the latest code. Mono 2.11.4 was released about 18 months ago.




On 12 January 2014 01:12, "Andrés G. Aragoneses" <knocte at gmail.com> wrote:

On 11/01/14 22:00, Grüninger, Andreas (LGL Extern) wrote:
> Hi all
> I compiled mono-2.11.4 on Solaris 11.1 and after excluding some tests
> the other tests succeeded. Only 2 failures. I prepared an upstream
> branch with the patches at
> https://github.com/grueni/mono/commits/upstream-mono-2.11.4.

Why such an old version and not master?

> Should I
> create pull requests?


Mono-devel-list mailing list
Mono-devel-list at lists.ximian.com


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-devel-list/attachments/20140115/2bb426a2/attachment.html>

More information about the Mono-devel-list mailing list