[Mono-dev] Mono 3 insert quotation marks instead of special chars in SQL Server

APS dev.malst at apsystems.it
Fri Jan 10 10:33:36 UTC 2014

While mailing-list system was offline I've done some further investigation.
The problem is during creation of RPC Call. It 
use tdsParameter.GetBytes method that make an Encoding.Default.GetBytes.
As the default Encoding is US ASCII avery special 
char is converted into a quotation mark. I've 
tried to change Default to UTF8 and Unicode, just 
to see what happens and it gives another error 
about wrong message format so it's not the correct way.
The old Mono 2 works because it use Tds70 instead 
Tds80 and Tds70 works in a different way, without using RPC.
I'm trying to workaround the problem downgrading 
to Tds70 and it seems to work, but there's a 
chance to have it working also with Tds80?

At 10:33 08/01/2014, APS wrote:
>I'm using mono 3 for an asp.net web application 
>and inserting or updating data in an SQL Server 
>database, if I enter special characters like 'à' 
>they are inserted as '?' inside the database.
>Is probably a conversion issue with UTF8 but how 
>can I handle it? I tried with an old mono 2 and 
>the characters has been inserted correctly.
>Any hint?
>Mono-devel-list mailing list
>Mono-devel-list at lists.ximian.com
>Il messaggio e' stato analizzato alla ricerca di virus o
>contenuti pericolosi da MailScanner, ed e'
>risultato non infetto.

More information about the Mono-devel-list mailing list