[Mono-dev] Building source fails: gmcs command not found

Chris Tacke ctacke at opennetcf.com
Thu May 16 13:36:16 UTC 2013

Tried the same thing under OpenSUSE 12.3 and I get the same failure, so I'm thinking it's not an environment problem, but a source code problem.


> -----Original Message-----
> From: mono-devel-list-bounces at lists.ximian.com [mailto:mono-devel-list-
> bounces at lists.ximian.com] On Behalf Of Chris Tacke
> Sent: Wednesday, May 15, 2013 2:43 PM
> To: mono-devel-list at lists.ximian.com
> Subject: [Mono-dev] Building source fails: gmcs command not found
> I'm trying to build Mono from the git source under a brand-new installation
> of Fedora 18.
> I'm following the instructions here:
> http://www.mono-project.com/Compiling_Mono_From_Git
> When I run make, I'm getting a failure after a while while it's attempting to
> make the runtime folder:
> if test -w /rootmono/mcs; then :; else chmod -R +w /root/mono/mcs; fi
> cd /root/mono/mcs && make --no-print-director -s NO_DIR_CHECK=1
> PROFILES=' net_2_0 net_3_5 net_4_0 net_4_5 ' CC='gcc' all-profiles
> make[6] gmcs: Command not found
> Now I'm pretty new to Mono - very, very new to trying to build it (first time)
> so I've got a steep learning curve to climb, but my reading of this:
> http://www.mono-project.com/CSharp_Compiler
>  is that gmcs is the old compiler for 2.0 and mcs should be what's being used
> for newer stuff.
> So I have a few questions.
> First, and most obviously, is how do I get Mono to build in this environment.
> Second, though, is I'd like to understand why this is failing.  Why is it trying to
> use gmcs in the first place?
> -Chris
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-devel-list

More information about the Mono-devel-list mailing list