[Mono-dev] Building Mono on OSX from GitHub

Daniel Lo Nigro lists at dan.cx
Thu Jan 31 23:28:26 UTC 2013

I've never used Mac OSX before - Does /usr/local/ exist? You might have to
use a different prefix (when you run ./configure or ./autogen.sh), it's the
--prefix option. Something like ./configure --prefix=/opt/mono/ where the
prefix path is wherever you want to install Mono to.

On Fri, Feb 1, 2013 at 10:18 AM, shmuelie <shmueli.yosef at englard.net> wrote:

> I thought I had but you gave me the idea to double check and I didn't!
> Installed them and tried to configure autoconfig and it worked! "make"
> worked too but sadly "make install" failed with:
> test -z "/usr/local/bin" || ../build-aux/install-sh -c -d "/usr/local/bin"
> mkdir: /usr/local: Permission denied
> mkdir: /usr/local: No such file or directory
> --
> View this message in context:
> http://mono.1490590.n4.nabble.com/Building-Mono-on-OSX-from-GitHub-tp4658394p4658400.html
> Sent from the Mono - Dev mailing list archive at Nabble.com.
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-devel-list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-devel-list/attachments/20130201/76f37fa9/attachment.html>

More information about the Mono-devel-list mailing list