[Mono-dev] Mysql Problems with mono

Crone marcel.croonenbroeck at gmail.com
Sun Feb 10 12:40:15 UTC 2013


I have coded in Visual Studio 2010(win7) an Application with a MySql

I have added the Assembly to the resources of my project and also added as
refernence to my resource dirctory.

Info: I use the mono mysql connector!

after compiling i moved all my files in the home directory of my server
(application.exe, MySql.Data.dll(old name mysql.data.dll)).

i use mono application.exe to start an got this error:

** (Server.exe:705): WARNING **: The following assembly referenced from
/home/MySql.Data.dll could not be loaded:
     Assembly:   System.Data    (assemblyref_index=1)
     Public Key: b77a5c561934e089
The assembly was not found in the Global Assembly Cache, a path listed in
the MONO_PATH environment variable, or in the location of the executing
assembly (/home/).

** (Server.exe:705): WARNING **: Could not load file or assembly
'System.Data, Version=, Culture=neutral,
PublicKeyToken=b77a5c561934e089' or one of its dependencies.

Unhandled Exception: System.TypeLoadException: A type load exception has
  at Server.MainCore.Main (System.String[] args) [0x00000]

what i have try:
gacutil -i MySql.Data.dll (same error)
rename mysql.data.dll to MySql.Data.dll (same error)
I have create a symbolic link with ln -s (same error)

I followed some tutorials but nothing worked. I hope some one can help to
solve my problem.

Sorry for my bad english and Thank you for your help

kind regards

Marcel (Crone)

View this message in context: http://mono.1490590.n4.nabble.com/Mysql-Problems-with-mono-tp4658532.html
Sent from the Mono - Dev mailing list archive at Nabble.com.

More information about the Mono-devel-list mailing list