[Mono-dev] Issues with gtk# menus?

Rob Wilkens robwilkens at gmail.com
Mon May 28 14:42:50 UTC 2012

On 05/28/2012 09:57 AM, Rob Wilkens wrote:
> I presume this is a gtk# problem, but not really, because i am running
> an old version of gtk# which worked with previous versions of mono...
> With the latest mono builds, with the same gtk# libraries, etc., that
> was running in 2.11.2 just fine, I have issues with monodevelop menus
> not showing up (the top menu). The program otherwise runs fine, but if I
> want to run a program inside monodevelop (either 2.x or 3.x) I have to
> press F5 for example, rather than clicking any of the menu options at
> the top because those menu options are not there.
> Anyone else notice this?
> Is this a known issue that's being worked on, or should i file a bug
> report?
> -Rob

BTW - The way I got monodevelop to run was as follows:
1) Set up a parallel build environemnt (installed mono with a prefix 
directory and setup environment with shell script) so it installed 'local'..
2) ran make/make install
3) went into old /usr/lib/mono/gac, and ran something like
find . -name *.dll -print| xargs -n1 gacutil /i
4) went back into mono build directory and reran make install so it 
would overwrite any old mono dlls, and presumably re-register them (not 
sure this was necessary, but it might have been).
5) then ran "mono /usr/lib/monodevelop/bin/MonoDevelop.exe' with local 
copy of mono.

More information about the Mono-devel-list mailing list