[Mono-dev] Compiling mono? I give up [not proceeding] - if anything obvious i'm doing wrong let me know

Marek Safar marek.safar at gmail.com
Tue May 1 19:22:48 UTC 2012


Here's the problem copied/pasted directly from command line of both
> programs:
> mono: symbol lookup error:
> /home/robwilkens/mono/lib/libglibsharpglue-2.so: undefined symbol:
> g_thread_supported

This is gtk-sharp issue when running on glib >= 2.31.

Plenty of info here,

Patch that fixes the issue https://gist.github.com/2570657

Jo Shields helped me to find it out.


> Oddly enough, i tried googling the error message (copy/paste) from
> libglibsharpglue to the end of the line, and nothing came up..  I
> guess i'm the first one to run across this particular problem, or at
> least the first to ask publicly.
> I get the same error from both programs that i was trying to test
> before (namely: monodevelop and GhettoGtkAdmin)...
> Is this mono or should i look for a gtk-sharp mailing list and ask there?
> Thanks,
> Rob
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-devel-list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-devel-list/attachments/20120501/d8936a8d/attachment.html>

More information about the Mono-devel-list mailing list