[Mono-dev] Compiling mono? I give up [not proceeding] - if anything obvious i'm doing wrong let me know

Oskar Berggren oskar.berggren at gmail.com
Tue May 1 14:56:39 UTC 2012

Perhaps you need to install libgtk2.0-dev via apt-get then?


2012/5/1 Rob Wilkens <robwilkens at gmail.com>:
> Copying list on my reply, sorry i keep forgetting i have to reply all..
> On 05/01/2012 10:09 AM, Rob Wilkens wrote:
>> 2.12.10 was the version i was building -- and yes, i suspect i have a gtk3
>> system (unity/ubuntu 12.04)...
>> I could try the experimental branch, but for what i'm doing right now it's
>> not important.  I might try it later if i can find it.
>> I just hacked gtk-sharp source as i described in other e-mail (manually
>> define to TRUE), which got me past that one problem.
>> I am now able to hunt down the original problem i was working on, i've
>> made some progress in narrowing it down, but don't have it yet.
>> -Rob
>> On 05/01/2012 10:04 AM, Alan wrote:
>>> What version of gtk+ do you have and what version of gtk-sharp did you
>>> build? The odds are you built gtk-sharp for gtk2 and you have gtk3
>>> installed on your system. There is an experimental branch of gtk-sharp
>>> which does work with gtk3 which might get around this problem for you.
>>> I think this is just a different branch in the regular gtk-sharp
>>> repository.
>>> Alan
>>> On 1 May 2012 13:45, Rob Wilkens<robwilkens at gmail.com>  wrote:
>>>> Ok, I've managed to get rid of most of my errors via using the
>>>> parallel build environment configuration...
>>>> But I've got one more error preventing me from proceeding with what i
>>>> wanted to work on, and i think it's related to gtk-sharp, in which
>>>> case i'm either asking on the wrong mailing list (probably) or maybe i
>>>> should find another version of gtk-sharp(?) to try to build.
>>>> Here's the problem copied/pasted directly from command line of both
>>>> programs:
>>>> mono: symbol lookup error:
>>>> /home/robwilkens/mono/lib/libglibsharpglue-2.so: undefined symbol:
>>>> g_thread_supported
>>>> Oddly enough, i tried googling the error message (copy/paste) from
>>>> libglibsharpglue to the end of the line, and nothing came up..  I
>>>> guess i'm the first one to run across this particular problem, or at
>>>> least the first to ask publicly.
>>>> I get the same error from both programs that i was trying to test
>>>> before (namely: monodevelop and GhettoGtkAdmin)...
>>>> Is this mono or should i look for a gtk-sharp mailing list and ask
>>>> there?
>>>> Thanks,
>>>> Rob
>>>> _______________________________________________
>>>> Mono-devel-list mailing list
>>>> Mono-devel-list at lists.ximian.com
>>>> http://lists.ximian.com/mailman/listinfo/mono-devel-list
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-devel-list

More information about the Mono-devel-list mailing list