[Mono-dev] Help running Mono on ARM/Linux

wallace lages wallace.lages at gmail.com
Fri Mar 2 21:35:53 UTC 2012

Hello everyone,

 I've been trying to run F# on a beagleboard with Angstrom for a while
without success.

 1-Compiled the managed parts on a Linux x86 host
 2-Crosscompiled the native parts on Scrachbox

 Tried both mono-2.10.2 and mono-2.10.9

 When running the F# interactive shell: mono ./fsi.exe I get:
 >* Assertion: should not be reached at mini-arm.c: 3289.

 The above line reads "NOT_IMPLEMENTED" at mini-arm.c:

 if(ainfo->storage == RegTypeGeneral || ainfo->storage == RegTypeIRegPair){
       switch(ainfo->size) {
       case 1:
       case 2:
This is inside the function "emit_load_volatile_arguments"

Looks like something is broken but I'm not sure how I can fix this.
Running the regression tests for the mini porting, I get 100% pass on the

   - basic.exe
   - basic-long.exe
   - basic-float.exe
   - basic-calls.exe
   - objects.exe
   - arrays.exe
   - exceptions.exe


   - iltests.exe  ->failed:21, (pass: 98.96%)
   - generics.exe-> Error loading type Typespec 0x1b000011 from due to
   Could not resolve typespec token 1b0000011
   Segmentation fault.

 So it really looks like something is wrong with the mono port or with my
 The fact of many tests passed explained why I can run the F# compiler to
compile HelloWorld but fail with the F# interactive interpreter.

Maybe it is something wrong with the crosscompilation, I tried:

./configure --prefix=/usr/local --disable-mcs-build CFLAGS=-DARM_FPU_NONE


./configure --prefix=/usr/local --disable-mcs-build --with-tls=pthread
--disable-shared-handles --with-glibc=embedded CFLAGS=-DARM_FPU_NONE

Any ideas ?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-devel-list/attachments/20120302/34f1ddc3/attachment.html>

More information about the Mono-devel-list mailing list