[Mono-dev] Embedding Mono

Robert Jordan robertj at gmx.net
Thu Mar 17 06:45:18 EDT 2011

On 17.03.2011 11:01, vinay_rk wrote:
> Hi,
> I' am compiling my App from MonoDevelop (with Gcc under the hood). I tried
> using mono_assembly_setrootdir to set the path to the mono Libraries where
> MonoPosixHelper.dll and libMonoPosixHelper.dylib are present but it doesn't
> change anything, I still get the dll not found exception. I also tried
> mono_config_parse with a dll map element to Map MonoPosixHelper to
> libMonoPosixHelper.dylib. This didn't help either.
> Regarding Otool and install_name_tool etc I am not able to follow the
> suggestions regarding them since I' am not familiar with Mac OSX
> development. I mainly develop on windows platform but am working on Mac now
> to make one of our apps cross platform.
> What else should I try now.. ??

Try this (before initializing the root domain):

mono_set_dirs ("/path/to/mono's/lib", "/path/to/mono's/etc");
mono_config_parse (NULL);


More information about the Mono-devel-list mailing list