[Mono-dev] creating excel files

Quandary quandary82 at hailmail.net
Tue Feb 22 02:48:55 EST 2011

mono 2.10 works fine on ubuntu

See my thread here on how to compile it yourselfs (just replace 2.8 with 
It takes about 30 minutes to 1 hour on a moderately modern computer.
An ideal in-between supper task.

I also tried EPPLUS on Linux several months ago, and there seems to be a 
bug in mono, something with the using directive and disposing too soon 
(on mono 2.6.7).
As I didn't have 2.8 then (freshly installed ubuntu on a new computer), 
I haven't filed a bug report, since it might have been already corrected.
It works fine on Windows, though.

You can also try

It also works fine outside of Silverlight, when you add the following 

See my fixes here:

It's the only FOSS .NET library I've found that's able to write .XLS 
files in BIFF format that can be opened with Excel 2010.
I don't know whether it runs on mono.
If you try, let me know the result.

I also have a console application for ExcelLite, if you want it, let me 
know (might save you 30 mins.).

Am 20.02.2011 18:57, schrieb eng. Ahmed Youssef:
> Hi,
> I need to create excel files from mono under Linux, and so I tried 
> two approaches:
> 1. Using the library EPPlus which works great under .net but not mono 
> (I tried 2.6.7 and later 2.10) although as far as I can tel from Moma 
> the only problem is the crypto module since it P/Invokes, It crashes 
> in the library zipsharp in System.IO.Packaging... the question here is 
> how do I debug into the mono library to discover what exactly is going 
> on in order to fix the library or patch the framework or whatever? the 
> tutorials says that after I GIT the source, the make process could 
> take 45 mns to 2hrs .... so I am kinda lost here! what exactly is the 
> best route to debug the framework library... I could try to copy the 
> files into my solution... but that could get tedious in case of lots 
> of dependencies so what is the best route to take?
> 2. I used CLI_UNO which works nicely in console, but when run from 
> mono 2.6.7 webapp in xsp2, it raises exceptions and fails
> "Ambiguous matching in method resolution" while setting the Thread 
> culture (which happens outside my code)
>  that happens even when xsp is run with sudo.... are there any knows 
> limitations between xsp and console that could prevent the code from 
> running?
> In case it matters to someone, here is the line that crashes:
>     componentLoader = 
> (XComponentLoader)multiServiceFactory.createInstance 
> ("com.sun.star.frame.Desktop");
> Another question: Are there any known plans by anybody to port mono 
> 2.10 to Ubuntu or the easiest way to stay up-to-date is to move to 
> Opensuse?
> Thanks a lot for the help....
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-devel-list

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20110222/afb8cff1/attachment.html 

More information about the Mono-devel-list mailing list