[Mono-dev] [mozroots]: Microsoft Office files can't be traced to a trusted root

jaysonp jaysonpryde at gmail.com
Mon Aug 29 20:42:01 EDT 2011

Hi Robert,

    Thanks for the feedback. :)
    I tried what you mentioned, but still, certs can't be traced to a
trusted root.

    However, I've indicated here some observations, which I hope will be of
great significance for this issue of mine to be resolved. Here it goes:

   1. The digital signature of WINWORD.EXE is already expired/invalid, but
it was countersigned. See snapshot below:

   2. I imported all the certs that were exported to all stores. (i.e Trust,
CA and My). Still no success.

   3. I tried to list the certs inside the Trust store using /certmgr -list
-c Trust/. But during the course of listing, I encountered an execption(s).
See below:


4. I dumped the certs found on Trust, CA and My store into a textfile. Now,
given that the counter signature was issued to WINWORD.EXE was issued by
Microsoft Timestamping Service/PCA, I expected that this string is present
on the list that I've just dumped (since I imported it using the powershell
script). But unfortunately, the text was not found. Does this mean that the
cert was not imported? See snapshot below:


Like what I mentioned, I hope the info I presented would help on resolving
the issue.

Thanks a lot!

View this message in context: http://mono.1490590.n4.nabble.com/mozroots-Microsoft-Office-files-can-t-be-traced-to-a-trusted-root-tp3775522p3777733.html
Sent from the Mono - Dev mailing list archive at Nabble.com.

More information about the Mono-devel-list mailing list