[Mono-dev] Moonlight and OSS4 sound ubuntu 9.10 and opensuse11.2

ted leslie tleslie at tcn.net
Tue Jun 29 22:17:01 EDT 2010

In setting up a new opensuse 11.2 install I installed google chrome and installed the preview moonlight
(without even thinking, as I thought moonlight didn't work with normal install with chrome),
it worked!!
But on the dr. dobbs  
silverlight/moonlight game the sound garbled up. (ran ok for 10 seconds then went all freaky).
This was probably do to it running in a vmware instance.
Youtube did the same (had sound issue).

So I installed oss4 as i really prefer it anyways over pulseAudio/alsa.
Youtube now works great, but there is no sound in moonlight.

I also tried the same game in my native host os ubuntu 9.10,  firefox and chrome (same test as in opensuse11.2),
and I also have OSS4 as my sound layer there as well. Also no sound in moonlight (dobbs game),
but sound work fine for everything else, flash, and wav, etc.(using this set up for over a year).

I can dig further, but perhaps someone "in the know" on moonlight, can very easily comment on why
sound doesn't work on linux with OSS4. Is it only made to work with alsa/pulse? It there a solution?

One of the  really poor things about linux is no good standard sound layer.
I have had set ups were pulseaudio works, other set ups where is pure broken.
I have used alsa standalone, but had little luck with multiplexing sounds.
I know others swear by Jack.
For me OSS4 works perfect. But as I see now, not with moonlight :(
I am thinking, if everything else works fine in browser (through to oss4), why not moonlight?

ted leslie <tleslie at tcn.net>

More information about the Mono-devel-list mailing list